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Keynote is an application you can use to create multimedia presentations. Text effects and transitions are smooth and 
elegant. It is also easy to hide graphic backgrounds using alpha transparencies. Animations can be created both using 
builds and motion paths.  There are excellent Keynote tutorials available online at Atomic Learning (http://www.
atomiclearning.com). The district username is grossmontu and the password is ______________.

Skills Covered:

Workspace Introduction P2 (F 1.1)
Inspector Window P2 (F 1.2)
Using Themes P3 (F 2.3)
Inserting Slides P3 (F 2.1)
Formatting Slide Backgrounds P4 (F 2.4-2.6)
Formatting Slides Using “Masters” Layouts P3 (F 2.2)
Inserting and Formatting Text P5 (F 3.1-3.3)
Formatting Bullets P5 (F 3.4)
Previewing Presentation P5 (F 3.5)
Adding, Resizing and Adjusting Images P6 (F 4.1-4.3) & P7 (F 4.4)
Using “Smart Builds” P8 (F 4.7)
Drawing and Using Shapes P9 (F 4.8-4.9) & P10 (F 4.10)
Masking P7 (F 4.5) & Alpha Masking P11 (F 4.14)
Using Graphic Strokes (Picture Frames) P8 (F 4.6)
Inserting Hyperlinks and Web Views P10 (F 4.11, 4.13)
Inserting Movies, Soundtracks and Special Effect Sounds P11 (F 5.1) & P12 (F 5.2-5.3)
Using “Build In” Progressive Bullet Disclosure P12 (F 6.1) & P13 (F 6.2-6.4)
Setting Slide Transitions P13 (F 6.5)
Using “Action Builds” P14 (F 6.6-6.7)
Exporting P15 (F 7.1)
Dual-Display Presenter Mode P15 (F 7.2)

I.	 Meeting Keynote

One of the strengths of Keynote is its wide variety of professionally designed presentation templates. Upon 
launch, choose an attractive design in the Theme Chooser or start with a solid white, black or gradient design. 
Keep in mind you can use more than one theme in a Keynote presentation. It is possible to disable the Theme 
Chooser from appearing at startup by clicking the “Don’t show this dialog box again” in the lower left corner of the 
window. 
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The workspace is very similar to PowerPoint. There are a variety of views in which to work including the default 
Navigator view, an Outline and Slide Only view, and the Light Table which is similar to the “Slide Sorter” view in 
PowerPoint. You can also choose to show or hide Presenter Notes in the lower window pane. Be sure the Inspector 
window and Format Bar are visible. Most elements of slide shows are controlled and formatted using the ten (10) 
different task-specific Inspectors.

The first theme used in today’s presentation is 
“Leather Book” with the “Title and Subtitle”  
Master slide selected for the first slide. 

The “Automatically play upon open” 
settings option should be selected 
under the Document Inspector.

1.2) The Inspector window is an essential 
element of the Keynote workspace.

1.1) The Keynote workspace looks very similar to PowerPoint. Switch to 
different views using the “View” drop-down menu. Make sure the Format 
toolbar is displayed from View > Show Format Bar.

Format Bar
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II.	 Inserting & Formatting Slides

To insert a slide, choose Slide > New Slide from the command menu or click the New (+) button on the 
toolbar. You can apply Masters layouts to slides. You will most often choose bulleted formats for slides, but there 
may be times when you want to apply other types of layouts. Insert 8 slides into your presentation.

2.1) Insert a new slide using the 
“New” button on the toolbar.

2.2) Apply content layouts to slides using the “Masters” drop-down menu...

2.3) Apply different themes to your slides by clicking on the 
“Themes” drop-down menu button.



    

4

Keynote_Class.pdf

To fill the slide background with color, a gradient or an image, use the “Background” controls in the “Appearance” 
pane of the Master Slide Inspector. Click the “Image Fill” drop-down menu under the word “Background.” To 
add a picture click “Choose...” and browse for the picture. Preview your presentation clicking the “Play” button 
and return to edit mode by clicking the [ESC] (i.e. Escape) key on your keyboard. Try using a tinted image as a 
background in one of your slides.

 

2.4) To insert an image as a background, click the “Choose...” 
button in the “Appearance” area of the Slide Inspector and 
browse for the picture on your computer. Taipei 101 bamboo.
JPG was used as the background image for the Day Three 
slide in the sample presentation. Choose “Scale to Fill” under 
the “Tinted Image Fill” drop-down.

2.5) The tint color was achieved by clicking “New 
from File...” from the “Palette” drop-down in the 
color picker and selecting the Leather Book 
Page.tiff image. After selecting the image, set the 
opacity to 83%.

2.6) A slide with a tinted image fill used as a 
background.
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III.	 Adding & Formatting Text, Previewing

The textbox guidelines seen on a slide are called placeholders. Double-click theses boxes to add your own text. To 
select, resize and/or move these boxes, click on the outer edge of the guide to reveal little boxes or handles. Type 
some text and format the type style using the formatting palette. Change the font type, color, size and other aspects 
of the text to achieve the desired effect. Add some titles and bullets to your slides and format as you desire.

3.2) To move the text box around on the slide, 
make sure you click the border’s outer edge. 
You can move the placeholder boxes when the 
handles are visible on the border.

3.1) A blinking cursor resembling a 
vertical line means you can type text 
inside the text placeholder.

3.3) To format text on the slide, either highlight it or click the border’s 
outer edge to select the entire text box. Then choose a font type, size 
and color from the appropriate drop-down menus.

3.5) Preview your presentation by clicking on the “Play” button in the top left corner of the toolbar. Return to edit mode by 
clicking the Esc key. If you have a scroll wheel mouse attached, you can use it to navigate through your slides during the actual 
presentation!

3.4) Format slide bullets from the Text Inspector’s 
“Bullets” tab.
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IV.	 Adding Images and Shapes

There are a number of ways to add images and other media into your Keynote presentation. From Insert > 
Choose... browse to locate and insert a file. You can also drag and drop files into Keynote, and even choose media 
located in your iLife applications using Keynote’s Media Browser. To show the media browser, go to View > 
Show Media Browser from the main menu. One of the coolest features of Keynote is the Smart Builds option 
which allows you to insert multiple pictures on a slide in sequential order or in various combinations! 

To resize an image after it has been inserted, click on it and drag the corner handles. You can arrange or stack 
elements (i.e. move to front or send to back) by selecting and choosing Arrange > Bring Forward or Arrange 
> Send Backward from the main menu. If you find yourself often stacking elements, consider personalizing 
your toolbar using View > Customize Toolbar and add these options as handy button shortcuts. There are 
many options to fine-tune your element’s appearance using the Graphic Inspector and “Adjust Image” floating 
palette. Insert Asia Terrain Map.pict (S3). Then, insert Country Store.JPG in S4 and Taroko National Park.
JPG in S5 to test Keynote’s “Image Adjust” feature.

4.1) Drag images from your iPhoto Library using the Media Browser. 
You can edit properties of your picture including its opacity, reflection 
level and drop shadow using the Graphic Inspector.

4.3) Grab an image’s corners to resize it.

4.2) Browse to insert images (and other media) 
by selecting “Choose...” from the “Insert” menu.
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Insert Countryside.JPG and Shucking Onions.JPG on S4, and National Palace.JPG on S7. Mask the images 
to your liking and set picture frames using the Graphic Inspector’s “Stroke” option. 

4.4) A modified version of iPhoto’s “Adjust Image” palette is available in Keynote. To reveal 
it, choose “Show Image Adjust” from the View menu.

4.5) The “Mask” option provides 
access to image cropping. Use 
the slider to zoom in or out on an 
image.
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Use Smart Builds to create mini slide-shows on each slide. Drag images from the Media Browser into the shaded 
box. It IS possible to rearrange the order of images after they are sequenced in the box. Keep in mind there are 
limitations with Smart Builds including the inability to mask (zoom in) and adjust images! As a workaround, make 
all needed adjustments to the image in iPhoto first before inserting into Keynote. Create Smart Builds on S4, S5 
and S7. Use at least 3-4 images in each build.

4.6) A number of different picture frame 
styles can be applied to both graphics 
and text boxes as “Strokes” using the 
Graphic Inspector.

4.7) Drag images from the “Media Browser” into the shaded box when creating “Smart Builds.” Resize the placeholder on 
the slide to maximize length and width of the slideshow images in both their portrait and landscape orientations. 
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Keynote has shapes in its library including arrows, squares, circles and lines. Use the Graphic Inspector to choose fill 
and border (stroke) colors for targeted shapes. It is also possible to send objects in front of and behind one another 
using Arrange > Bring Forward, and combine shapes using the Arrange > Group option from the menu 
bar. Create the airplane graphic as seen in the sample presentation on S3.

4.8) The small airplane graphic in the sample presentation was 
created using an oval shape, two triangle shapes and two right 
triangles. The 270 degree gradient fill was a combination between 
white and a color with 70, 70 and 88 RGB values. Stroke and 
shadow values are shown below.

4.9) Shapes can be grouped together as one object and rotated using the “Rotate” option in the Metrics Inspector.
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Shapes can be used as button symbols to link slides sequentially in a presentation. This is very similar to how 
“Action Buttons” are utilized in PowerPoint. Draw a shape, select it and click the Hyperlink Inspector. Check the 
box next to “Enable as a hyperlink” and choose the appropriate “Link To:” option from the drop-down menu. 
Insert an arrow shape on S2, duplicate it and rotate or flip accordingly. Respectively align these left and right 
arrows into the top corners of the slide and enable each as hyperlinks to their corresponding “Next” and 
“Previous” slides. Copy and paste this arrow set across the remaining slides in the presentation.

4.13) Almost any element on a slide can be enabled as a hyperlink to either another slide or a Web site. It is also possible to 
insert Web Views (Insert > Web View) in Keynote slides, which are live Web pages which display as images!

4.11) Click the “Enable as a hyperlink” option in the 
Hyperlink Inspector to enable the shape as a button.

4.12) Rotate shapes from the Metrics Inspector (looks 
like a little ruler).

4.10) Click the Shapes 
button on the toolbar to 
insert arrows.



    Introduction to Apple Keynote
    

11

Jim Epler © 4/2008, Educational Technoloy Resources

4.14) Use “Alpha” masking techniques to make parts of 
an image transparent. This is a REALLY cool feature!

V.	 Adding Media

It is very easy to add multimedia to your presentation including music 
and video. If you plan to move your presentation to another computer, 
be sure that “Copy audio and movies into document” is selected under 
the “Advanced Options” as shown in the Save or Save As windows.

It is possible to insert audio directly from your iTunes music library 
using the Media Browser. Designate for the music or movie clip to “start 
on click” or automatically under the Quicktime Inspector. Poster frames 
can also be set here. 

Insert Signet Tours.mov into S2. Then, insert Soundtrack Music.wav 
into the soundtrack area of your presentation using instructions 
listed on the next page.

5.1) The Quicktime Inspector.

Insert a Web View on S6 to http://www.taroko.gov.tw/. Then, insert Museum Coral.JPG on S8 and use the 
alpha masking technique to make lighter portions around the border of the coral in the picture transparent.
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Presentation soundtracks can be set in the Document Inspector under the “Audio” area. Drag in an audio file and 
adjust the volume and play option (loop, play once or off) accordingly.

VI.	 Adding Motion (Animation) & Transitions

It is often desirable to have bulleted items on a slide displayed with progressive disclosure. Meaning, the first 
bulleted item appears before the second bulleted item, and so forth. You can easily achieve this effect using 
animation options available from the Build Inspector. Animating elements in Keynote is referred to as building. 
Slide transitions are also common techniques used to enhance presentations. Set these from the Slide Inspector’s 
“Transition” option. Other elements such as graphics can even be animated on pre-determined paths using “Action 
Builds!”

6.1) Select the text box with the bullets and switch to the Build Inspector to 
easily build progressive disclosure sequences using the “Build In” option.

5.2) It is possible to set a poster frame for the movie using the slider available in 
the Quicktime Inspector.

5.3) Soundtracks can be added under 
the Document Inspector’s “Audio” tab.
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Do a “Build In” with the “Trip of a Lifetime” text box on S2 using the “Comet > Left to Right” animated 
effect. Then, try “Build In” animations with bulleted items on S4, S5 and S7. Set slide transitions for all 
eight slides.

6.2) Click the “More Options” button at the bottom of 
the Build Inspector to reveal specifics related to the 
animated order of objects on the slide.

6.3) Objects can be dragged up or down 
in the “Build Order.”

6.4) Objects can be animated “On Click,” 
“Automatically” AFTER another build, or 
“Automatically” WITH another build.

6.5) Slide transitions can be set from the Slide 
Inspector’s “Transition” “Effect” option.
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6.7) Action builds allow you to animate objects along straight or curved paths. This particular type of animation is not 
available in PowerPoint.

Use “Action Builds” to make objects move, rotate, and grow larger or smaller on a slide. Select the object (an 
image, shape, text box, chart, movie or other media file, or table) on the slide and open the Build Inspector. Click 
“Action” and choose “Move” from the “Effect” pop-up menu. A red line connected to a ghosted (transparent) 
version of the object appears, showing the object’s destination. Drag the ghosted object somewhere on the slide. 
Additional actions such as “Opacity,” “Rotate” or “Scale” can be added to the object’s build by clicking the “Add 
Action” plus sign (+) box.

6.6) Drag the transparent version of the object in a “Move” action build. Additional actions can be joined to the animated 
sequence using the “Add Action” button.
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VII.	Final Delivery

You can export Keynote presentations as Quicktime files or Flash movies, but keep in mind this works best in 
simple presentations that do not include an abundance of multimedia or contain complex builds and animations. 
Choose File > Export and choose a format from the multitude of options available.

Additionally, it is possible to present your slideshow with a dual-display configuration (one display for you “the 
presenter” and the other for your students “the audience”). This is similar to the “View Presenter Tools” option 
in PowerPoint. In fact, it is even possible to customize the presenter’s second screen using the menu command 
Keynote > Preferences > Presenter Display Preferences. Click the “Edit Presenter Layout...” button to 
adjust and manage your own personal presenter layout!

7.1) Keynote export wizard.

7.2) Place a checkmark in the “Use 
alternate display...” checkbox to enable 
dual-display presenter mode. It is also 
possible to create a your own presenter 
display layout in Kenote! Very cool!


