Introduction to Apple Keynote Q

Keynote is an application you can use to create multimedia presentations. Text effects and transitions are smooth and
elegant. It is also easy to hide graphic backgrounds using alpha transparencies. Animations can be created both using
builds and motion paths. There are excellent Keynote tutorials available online at Azomic Learning (http://www.

atomiclearning.com). The district username is grossmontu and the password is

Skills Covered:

Workspace Introduction 72 (F 1.1)

Inspector Window P2 (F 1.2)

Using Themes 73 (F 2.3)

Inserting Slides 73 (F 2.1)

Formatting Slide Backgrounds P4 (F 2.4-2.6)

Formatting Slides Using “Masters” Layouts 73 (F 2.2)

Inserting and Formatting Text 75 (F 3.1-3.3)

Formatting Bullets 75 (7 3.4)

Previewing Presentation P5 (F 3.5)

Adding, Resizing and Adjusting Images 6 (F 4.1-4.3) ¢ P7 (F 4.4)
Using “Smart Builds” 78 (F 4.7)

Drawing and Using Shapes 9 (F 4.8-4.9) ¢ P10 (F 4.10)

Masking 7 (F 4.5) & Alpha Masking P11 (F 4.14)

Using Graphic Strokes (Picture Frames) 78 (F 4.6)

Inserting Hyperlinks and Web Views P10 (F4.11, 4.13)

Inserting Movies, Soundtracks and Special Effect Sounds P77 (F 5.1) ¢ P12 (F 5.2-5.3)
Using “Build In” Progressive Bullet Disclosure P12 (F 6.1) & P13 (F 6.2-6.4)
Setting Slide Transitions 713 (F 6.5)

Using “Action Builds” P74 (F 6.6-6.7)

Exporting P15 (F 7.1)

Dual-Display Presenter Mode P15 (F 7.2)

I. Meeting Keynote

One of the strengths of Keynote is its wide variety of professionally designed presentation templates. Upon
launch, choose an attractive design in the 7Zheme Chooser or start with a solid white, black or gradient design.
Keep in mind you can use more than one theme in a Keynote presentation. It is possible to disable the 7heme
Chooser from appearing at startup by clicking the “Don’t show this dialog box again” in the lower left corner of the

window.
{ e }IL

Gradient Headlines

Choose a theme for your presentation:

Lo LA
Craft
e BLUEPRINT
Craft Blueprint
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The workspace is very similar to PowerPoint. There are a variety of views in which to work including the default
Navigator view, an Outline and Slide Only view, and the Light Table which is similar to the “Slide Sorter” view in
PowerPoint. You can also choose to show or hide Presenter Notes in the lower window pane. Be sure the nspector
window and Format Bar are visible. Most elements of slide shows are controlled and formatted using the ten (10)

different task-specific Inspectors.
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View emes  Masters

Untitled 2
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Text Box Shapes Table Charts Comment Smart Builds
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Double-click to edit

Double-click to edit

= Format Bar

Hide Comments

The first theme used in today’s presentation is
“Leather Book” with the “Title and Subtitle”
Master slide selected for the first slide.

AN Document
(DE}«_\ T®¢8Ha0a
-“lcument | Audio

Slideshow Settings

Spotlight -

Automatically play upon open
" MLoop slideshow

Press 'Esc’ key to exit
"] Restart show if idle for: 15m -

" Require password to exit show

Presentation = Normal

Delay:

Transitions Builds

Slide Size 1024 x 768 s

The “Automatically play upon open”
settings option should be selected
under the Document Inspector.

%

1.1) The Keynote workspace looks very similar to PowerPoint. Switch to
different views using the “View” drop-down menu. Make sure the Format
toolbar is displayed from View > Show Format Bar.

Slide

o)< T2 ¢ B 1l @&

{ Transition | Appearance

Effect

' Mone

Y
Iy

)

Direction

Duration

1.2) The Inspector window is an essential
element of the Keynote workspace.
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Introduction to Apple Keynote

II.

Inserting & Formatting Slides

a,

To insert a slide, choose Slide > New Slide from the command menu or click the New (+) button on the
toolbar. You can apply Masters layouts to slides. You will most often choose bulleted formats for slides, but there
may be times when you want to apply other types of layouts. Insert 8 slides into your presentation.

eoe
* B,

i) Play Wiew

— Add a new slide. =

—— -
2.1) Insert a new slide using the
“New” button on the toolbar.

e |

B Title & Subtitle

Bullets
Blank
Title - Top

|| Title - Center

Photo - Horizental
Photo - Vertical
Title, Bullets & Photo
Title & Bullets - Left

Title & Bullets - Right
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2.2) Apply content layouts to slides using the “Masters” drop-down menu...
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oose a theme for the selected slides or the
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.

Theme Chooser...

White ‘ | HEADLINES &

entire slideshow.
|
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2.3) Apply different themes to your slides by clicking on the

“Themes” drop-down menu button.
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To fill the slide background with color, a gradient or an image, use the “Background” controls in the “Appearance”
pane of the Master Slide Inspector. Click the “Image Fill” drop-down menu under the word “Background.” To

add a picture click “Choose...” and browse for the picture. Preview your presentation clicking the “Play” button
and return to edit mode by clicking the [ESC] (i.e. Escape) key on your keyboard. Try using a tinted image as a
background in one of your slides.

Slide- 888 Celers =

(=) T 2 & Bl @G O & fp =l =
\'F'/ — Q
. Transition W

|
Master & Layout Image:  Leather Book Page H

k3
Title, Bullets & Photo o
Mew from File...
E Title | Object Placeholder Rename...
Remowve
™ Body ! slide Number Copy
Mew from Pasteboard
Background ' Palette
. . .
_ Tinted Image Fill I-#-] Opacity
[ N -
: . Scale to Fill 4] I
( Choose... l - = 2.5) The tint color was achieved by clicking “New
from File...” from the “Palette” drop-down in the

color picker and selecting the Leather Book
Page.tiffimage. After selecting the image, set the
opacity to 83%.

2.4) To insert an image as a background, click the “Choose...”
button in the “Appearance” area of the Slide Inspector and
browse for the picture on your computer. Taipei 101 bamboo.
JPG was used as the background image for the Day Three
slide in the sample presentation. Choose “Scale to Fill” under
the “Tinted Image Fill” drop-down.

o
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=
[
[l
i
[l
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= |

Double-click to edit

2.6) Aslide with a tinted image fillusedasa [[if = mommmmeeemmm———
background.

= Double-click to edit

b
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The textbox guidelines seen on a slide are called placeholders. Double-click theses boxes to add your own text. To
select, resize and/or move these boxes, click on the outer edge of the guide to reveal little boxes or handles. Type
some text and format the type style using the formatting palette. Change the font type, color, size and other aspects
of the text to achieve the desired effect. Add some titles and bullets to your slides and format as you desire.

III. Adding & Formatting Text, Previewing

J-‘;"I. LJ__I_‘\J_T [ @06 Untitled =]
rrmn
¥ T, B WoEd O & B % H,
New Play View Themes Master Text Box Shapes Table Charts Comment Smart Builds
| Baskanvilie i | [ Regular | [0\ I:I||E|I|g|‘|§|§|§|§||§|l.0 2] =

Slides

Taiwan Adventures

3.1) A blinking cursor resembling a
vertical line means you can type text

May 2007
inside the text placeholder.

= 5 11| 50%
T —

3.3) To format text on the slide, either highlight it or click the border’s
outer edge to select the entire text box. Then choose a font type, size
and color from the appropriate drop-down menus.

—

3.2) To move the text box around on the slide, - £

Text
make sure you click the border’s outer edge.
You can move the placeholder boxes when the
handles are visible on the border.
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umns | Bullets

“" Indent Level 1

211;-1' Bullets & Numbering

Image Bullets

Align:3  0pt

~ @ S
= {@ & size: [ 100%](%)
3.4) Format slide bullets from the Text Inspector’s 4 Choose an image to use as a bulet.
“Bullets” tab. o i
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Bullet Indent:

Text Indent:

3o ~

@06
H [ B, G, M=,

Mew F‘Ia'gr% View  Themes Masters Text Box

lmPla\r the slideshow from the selected slide.

3.5) Preview your presentation by clicking on the “Play” button in the top left corner of the toolbar. Return to edit mode by

clicking the Esc key. If you have a scroll wheel mouse attached, you can use it to navigate through your slides during the actual
presentation!
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IV. Adding Images and Shapes

There are a number of ways to add images and other media into your Keynote presentation. From Insert >
Choose... browse to locate and insert a file. You can also drag and drop files into Keynote, and even choose media
located in your iLife applications using Keynote’s Media Browser. To show the media browser, go to View >
Show Media Browser from the main menu. One of the coolest features of Keynote is the Smart Builds option
which allows you to insert multiple pictures on a slide in sequential order or in various combinations!

To resize an image after it has been inserted, click on it and drag the corner handles. You can arrange or stack
elements (i.e. move to front or send to back) by selecting and choosing Arrange > Bring Forward or Arrange
> Send Backward from the main menu. If you find yourself often stacking elements, consider personalizing
your toolbar using View > Customize Toolbar and add these options as handy button shortcuts. There are
many options to fine-tune your element’s appearance using the Graphic Inspector and “Adjust Image” floating
palette. Insert Asia Terrain Map.pict (S3). Then, insert Country Store.JPG in S4 and Taroko National Park.
JPG in S5 to test Keynote’s “Image Adjust” feature.

55T [®@a6 Untitled )
0 ®<e B s a0 al i, B, 8 al, [ W, . S ST R
5 Masters  Text Box Shapes Table Charts Comment Smart Builds Mask  Alpha Back Inspectar
Fill — | - T | S | 2 & [ |Stroke: None 3| = |Fi||:
8086 Media
Audic | Photos | Movies |
. =
Double-click to ¢ [v@wme
- i : - I Library
Swoke  EEIESNERea RS- N\ . p[FRolls
Line ] ¥ Last Roll
< =@ ] Last 12 Months
—™ I—I_ Py BALBOA PARK -
Endpoints: ) : | M TriproAsa |
™ shadow B
—m
EI Angle: Q 315° | 5]
<) <y <
6 px = 10 px =) 75% =)
Offset Blur Opacity Buddhist Temple
Eternal Springs S...
™ Reflection s
Opacity .
Y 69% 5
E - Mational Palace Shucking Eggs m

Slide Format

Column Break

Text Box

Shape >
Table

Function |
Chart

Smart Build >

Comment
Web View

Tavwt byusaelisle [
PCALTTY ETTTTR L

~ Choose... 8V

4.1) Drag images from your iPhoto Library using the Media Browser.
You can edit properties of your picture including its opacity, reflection
level and drop shadow using the Graphic Inspector.

w: 1115 px h: 742 px

4.3) Grab an image’s corners to resize it.

4.2) Browse to insert images (and other media)
by selecting “Choose...” from the “Insert” menu.
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VIS Window  Help

Play Slideshow
Show Colors

Double-ch

Adjust Image

Erightness: % e—=—=—— &

Contrast: O

Show Adjust Image
Show Media Browser®
Show Document Warnin

e ey

Saturation: [I]
Temperature:
Tint:

Sharpness

Exposure:

Reset Image l

T

4.4) A modified version of iPhoto’s “Adjust Image” palette is available in Keynote. To reveal
it, choose “Show Image Adjust” from the View menu.

Insert Countryside.JPG and Shucking Onions.JPG on S4, and National Palace.JPG on S7. Mask the images

to your liking and set picture frames using the Graphic Inspector’s “Stroke” option.

., [m, [T W, B afl. 1 &,

Themes Masters Text Box Shapes Table Charts Comment Smart Builds =}
0 : | elrull|l====1|F Mask Alpha
i | | === E_
L RS arve— —
Double-click to edit—— Mask (crop) the selected image. -
m| m|

Edit Mask |

T
4.5) The “Mask” option provides
access to image cropping. Use
the slider to zoom in or out on an
image.

MR
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4.6) A number of different picture frame [ = = D I & d é“]ﬁ AQAF & T 1
Styles can be app“ed to both graphics :s e:s Te:( S:s T Fill i -\: _g‘ ’T. on
and text boxes as “Strokes” using the  ieie— 1 & mm (8] (Nore B B |soel 3]
Graphic Inspector. = '
| Stroke
=== [ picture Frame I-G-i “““““
| A
= Scale N
»-National Pal —® [100%][}
Museum ! ="
# shadow
l:l Angle 315° |f5
@ Taipei 101 | = = =
3 px - 1px - 90% =
il i Offset Blur Opacity
--&-Dampel’ BaH __| Reflection —
|
| Opacity =
-p Street Scené: : e
[m} O

Use Smart Builds to create mini slide-shows on each slide. Drag images from the Media Browser into the shaded
box. It IS possible to rearrange the order of images after they are sequenced in the box. Keep in mind there are
limitations with Smart Builds including the inability to mask (zoom in) and adjust images! As a workaround, make
all needed adjustments to the image in iPhoto first before inserting into Keynote. Create Smart Builds on S4, S5
and S7. Use at least 3-4 images in each build.

2] 6 (3] Untitled

8 00 Build - m. E Jql. [ i
D .‘Q‘T |p <§ @ .uﬂ[l. 0 @exl Box Shapes Table Charts Comment Smart B

'+]

Trip to Asia

i-'l' f By ;l: | =]l | EE[=]S1] F|
pnt  Smart EuiEs p’
7 - ] Day On
| | Dissolve [ RN E sy AR
=< Flip -
— Grid L Build In | Builds
JMrough (1 image)
Push
Thumb Threugh
ShufﬂE Direction
Spln From Left
Spinning Cube Build from iy SN JBE |
S-WEF! | Set separate tim
Thumb Through
Turntable

T

T e ety

e
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4.7) Drag images from the “Media Browser” into the shaded box when creating “Smart Builds.” Resize the placeholder on
the slide to maximize length and width of the slideshow images in both their portrait and landscape orientations.
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Introduction to Apple Keynote QO

Keynote has shapes in its library including arrows, squares, circles and lines. Use the Graphic Inspector to choose fill
and border (stroke) colors for targeted shapes. It is also possible to send objects in front of and behind one another
using Arrange > Bring Forward, and combine shapes using the Arrange > Group option from the menu
bar. Create the airplane graphic as seen in the sample presentation on S3.

FTALIICE FTESENTI)
|:| E mmm |:| i 4.8) The small airplane graphic in the sample presentation was
T ¥ i created using an oval shape, two triangle shapes and two right
p Shapes Table Charts Comment Smart Builds | triangles. The 270 degree gradient fill was a combination between

— — white and a color with 70, 70 and 88 RGB values. Stroke and

| plr lull =T=T=1=1| %] T had : h bel
|Choose a shape to add to this slide. ] SNadow values are shown below.

800 Zzohic
B8 Colars = 0 =<= ] @y@ﬂlﬂ@
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L W || e = Fill
| Gradient Fill I%]

, _ OO0 Angl :O [+15]
lﬂgd RGB Sliders il E: T 270°
e ' |

|
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‘ﬂ
%
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T Line
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Blug | |
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IEI Angle.O 315° ||+
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3 px o 5 px o 77k -
Offset Blur Opacity
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1 1
- ,fi! 100 | % __| Reflection
Opacity .
4 - & | 100% |5

L

Slide Format Arrange View Window Help W, EH . i . (= X = By B
o6 Bring Forward T F Trip to Asi3 x Shapes Table Charts Smart Builds Ungroup Back
>l Bring to Front 0 38F | B | ElEEE | = 2 [m4 900 ’getfics ™. | =
" % ['\ﬁ,,' Send Backward ~ X{®B oo, c“"mj,ﬂn; snﬁ;,ds 2 30 52 0= T - 2 @)u[t G QaH
e Send to Back {#B IE | = File Info \ p'
Slides | Align Objects > fB

Distribute Objects >
Flip Horizontally size 38px 2] 26px 2
Flip Vertically Width Height

"] Constrain proportions

Lock
Unleck

Original Size

Position 809 px (3] 407 px (3]

/! Mgle Flip

4.9) Shapes can be grouped together as one object and rotated using the “Rotate” option in the Metrics Inspector.

JIM EPLER © 4/2008, EDUCATIONAL TECHNOLOY RESOURCES



4@

Shapes can be used as button symbols to link slides sequentially in a presentation. This is very similar to how
“Action Buttons” are utilized in PowerPoint. Draw a shape, select it and click the Hyperlink Inspector. Check the
box next to “Enable as a hyperlink” and choose the appropriate “Link To:” option from the drop-down menu.
Insert an arrow shape on S2, duplicate it and rotate or flip accordingly. Respectively align these left and right
arrows into the top corners of the slide and enable each as hyperlinks to their corresponding “Next” and
“Previous” slides. Copy and paste this arrow set across the remaining slides in the presentation.

v [ =
hemes Masters

= e | O v

Hyperlink

=3 g —T

Text © O O

ular

+] |32

4.10) Click the Shapes
button on the toolbar to
insert arrows.

" ™ Enable as a hyperllnk/“

Link To:

" Slide

! Last slide

\_ Last slide viewed

O slide -]

103 T2 ¢ B u@:

5060
0®<T

File Info

i:‘;E\mﬂu@

v

Size

"
-
e

100 px
Width

Ol px
Height

] Constrain proporticns

4.11) Click the “Enable as a hyperlink” option in the
Hyperlink Inspector to enable the shape as a button,

4.12) Rotate shapes from the Metrics Inspector (looks
like a little ruler).

/ -{\\ Original Size
4 |

O O <y <

Position 39 px . IS px .
X Y
Mo}
Rotate ( ) eoe’E) &g
Angle Flip

_Change the angle of the object.

Keynote File Edit .ml Slide Format Arrange View Window Help
eee Column Break Untitled [=]
[ E, B, Text Box (b, [ i- =] = S| . &
New Play View  Theme: Shape > Charts Comment Smart Builds Front
Table B | | T =@ | stroke: :
Slides = w4 Function » = ) Hyperlink \
Chart 03¢ T 2 & | B\l & C |
i - Smart Build L3 E Enable as a hyperlink " 1
(]
B £/ Comment Link To: Webpage 3 '
ah |
2 Text vaer"nk » URL: | hrtp:/ fwww.taroko.gov.ow/ I
| |
Display: B
] Choose... RV bl |
2 !
ry E Update automatically !
4 (" UpdateNow ) |
-
o
Tarolso NMNational Paxlc
ICE T A

4.13) Almost any element on a slide can be enabled as a hyperlink to either another slide or a Web site. It is also possible to
insert Web Views (Insert > Web View) in Keynote slides, which are live Web pages which display as images!
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Insert a Web View on S6 to http://www.taroko.gov.tw/. Then, insert Museum Coral.JPG on S8 and use the
alpha masking technique to make lighter portions around the border of the coral in the picture transparent.

R H G ® L
Mask Alpha. Croup Ungroup Fromt Back In
| stroke: WE—L- . Ll

) —rl"-lalr.e parts of an image transparent.

4.14) Use “Alpha” masking techniques to make parts of
an image transparent. This is a REALLY cool feature!

Click the color you want o make trans

then drag. As you drag, the selection grows
to include areas that use similar colors.

Drag multiple times to make other areas
transparent. When finished, press Return.

Q
o
V. Adding Media
It is very easy to add multimedia to your presentation including music - E =R
. . D IEI <T@ 2 |8l
and video. If you plan to move your presentation to another computer,
Start & Stop

be sure that “Copy audio and movies into document” is selected under T <
the “Advanced Options” as shown in the Save or Save As windows. . s

Poster Frame
&

It is possible to insert audio directly from your iTunes music library
using the Media Browser. Designate for the music or movie clip to “start —

on click” or automatically under the Quicktime Inspector. Poster frames (None
can also be set here.

s Start movie on click

Volume

o+
Insert Signet Tours.mov into S2. Then, insert Soundtrack Music.wav S
into the soundtrack area of your presentation using instructions CICIGICIC)

00:00:08.32 00:03:38.80
listed on the next page.

Play or pause the movie.
—_—

5.1) The Quicktime Inspector.
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Presentation soundtracks can be set in the Document Inspector under the “Audio” area. Drag in an audio file and
adjust the volume and play option (loop, play once or off) accordingly.

eos

<! Trip o Asia

= =05 N
uﬂ LL- I\.n:' TE.J-' E' Tmlu T?I- :!' I ~ im.‘;v'u B S N r% _Tl' i o :f » @ = I
i Pay £ n Mastern Tt ] ity Commast rt Baildn Mash  Alphs Crmmp Ungeoup From  fack Intpacbor Cl =
R (BT @ ¢ 5 al @a
Slides 1% [, | @ AL IL] [ L T8 3 = .. J

h S

AT TR N e
DE e T ¢ Ealel \
Start & Stop !

— |
cinmm gz i '
Pastar Frame X - L
~ 3 ) ] Ll ||
¥ Start mowie on cick ¢ the frame to display watil the movie
| begins playing. i

Yelume
o —

Contrals

PRI R ST
[T FIT ETEs

i
i

' Document | Audio | Spotlight ]—

b

“ Soundtrack '\_\
[ T r_L‘)va:-;:- FH
CI| —F
LT I':/ iTunes Library )

\I";'j/‘u'ﬂlume -
e o —? L

Slideshow Recording Adjust the volume
T—

(C )

Volume

of:

N

Record. .. Clear...

.’ =% *,:3.

5.3) Soundtracks can be added under

the Document Inspector’s “Audio” tab.

1 K1

o

5.2) It is possible to set a poster frame for the movie using the slider available in

the Quicktime Inspector.

VI. Adding Motion (Animation) & Transitions

It is often desirable to have bulleted items on a slide displayed with progressive disclosure. Meaning, the first
bulleted item appears before the second bulleted item, and so forth. You can easily achieve this effect using
animation options available from the Build Inspector. Animating elements in Keynote is referred to as building.
Slide transitions are also common techniques used to enhance presentations. Set these from the Slide Inspectors
“Transition” option. Other elements such as graphics can even be animated on pre-determined paths using “Action

Builds!”
(6] g‘\’ Build B
] Dag‘ ETppsed0a
p—_ Day One
2 | i
o e . . - | -
b ‘Ilanyuallj Talwan ‘
3o f\b@rigj.ll-l \Tﬂlaqe Build Out | Action :
| = Effect
o] Swoosh El by Object | 5 P
i b Len\vu Direction Order
i | et BIFTEE] - -
| <= Local Ten]ple Delivery Duration
1 [ By Bullet 1.00s S =
2 | —
0] o2 Countl"VSidf! Build from | First 9‘ lg:\;.:;;E\:hae"th;[rutnct?:lc:;e:;;‘l:bles. charts,
z ) Set timings fi -
cal

-

6.1) Select the text box with the bullets and switch to the Build Inspector to
easily build progressive disclosure sequences using the “Build In” option.

KEYNOTE_CLASS.PDF



Introduction to Apple Keynote

Inspector Media Cal

| fi|— |

[nnr\r (.m:n Ruilde ch Alnba  Croun
Bulld

E'D[ &‘@ﬁ@mﬂﬁ)@"

| R

!1- T _' =

‘—{-—Dnﬂd-h—| Build Out | Action —— .

Effect

| | Swoosh m by Object =
Direction Order .
[ Left (2 ™
Delivery Duration
f <}
By Bullet ﬂ 1.00s
Build from  First @ to | Last @
ESet p timings for el 5

( Maore Options )
>

ange the order in which objects build and
set timings for automatic builds.

6.2) Click the “More Options” button at the bottom of
the Build Inspector to reveal specifics related to the
animated order of objects on the slide.

Do a “Build In”

:I.
H
1,

Build Order

# | Object Build
1 = Bullet: Jianyua... In
2 e Jianyuan Thu. l[
3 . Aﬂernﬂon MNan  Thu
4 LTy stare_ g T
5 L "u"lllage Music In
6  Totem Pole Thu.
E 7 o+ Totem Pole 2 Thu.
& « Drumming Thu.

6.3) Objects can be dragged up or down
in the “Build Order.”

14 = Lenwu Thu...
| | 16 = MrLin Lenwu Thu...
17 » Temple Spires Thu...
18 » Temple Outside Thu...
19 «» Temple Gods Thu...
20 « Temple Gods 2 Thu...
21 « Wild Hog Thu...
22 » Caged Dog Thu...
11 23 = Shucking Onio... Thu... i |
24 e Bullet: Local T... In r
On Click ¥
Automatically after build 14
¥ Automatically with build 14

6.4) Objects can be animated “On Click,”
“Automatically” AFTER another build, or
“Automatically” WITH another build.

with the “Trip of a Lifetime” text box on S2 using the “Comet > Left to Right” animated

effect. Then, try “Build In” animations with bulleted items on S4, S5 and S7. Set slide transitions for all

eight slides.

slide |
T'@'i‘?'%!nﬂﬂ.lo!a'

Appearance

{05 Flight

”.l"-{f/

e

=t ol
i ()
Page Flip @ 00s | o
Direction
| Left 4]
Start Transition Delay
On Click B‘ 0.0s .

¥ MNone

3D Effects
Blinds

Color Planes
Confetti
Cube
Doorway
Fall

Flip

Mosaic

Reflection E

Revolving Door
Swap
Swoosh

2D Effects

Blur

6.5) Slide transitions can be set from the Slide
Inspector’s “Transition” “Effect” option.

Dissolve

Droplet

Fade Through Color
Flash
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Use “Action Builds” to make objects move, rotate, and grow larger or smaller on a slide. Select the object (an
image, shape, text box, chart, movie or other media file, or table) on the slide and open the Build Inspector. Click
“Action” and choose “Move” from the “Effect” pop-up menu. A red line connected to a ghosted (transparent)
version of the object appears, showing the object’s destination. Drag the ghosted object somewhere on the slide.
Additional actions such as “Opacity,” “Rotate” or “Scale” can be added to the object’s build by clicking the “Add
Action” plus sign (+) box.
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Ruild In | Ruild ©wtr | | Action
}i-] P i Mone
+ | Add Action Order
* ¥ Move 3 s
F—eiol racity Path
m Rotate
e —_— ™
, ]
Duration

H:".
1.00s [37)

6.6) Drag the transparent version of the object in a “Move” action build. Additional actions can be joined to the animated
sequence using the “Add Action” button.
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6.7) Action builds allow you to animate objects along straight or curved paths. This particular type of animation is not
available in PowerPoint.
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Introduction to Apple Keynote QO

VII. Final Delivery

You can export Keynote presentations as Quicktime files or Flash movies, but keep in mind this works best in
simple presentations that do not include an abundance of multimedia or contain complex builds and animations.
Choose File > Export and choose a format from the multitude of options available.

Trip to Asia
i N Dy Dy &y = |ﬁ| b
M Q PET] PO ] [PNG] [SWE] @ O fc
= .
. QuickTime PawerPaint PDF Images Flash HTML iPod F|
I 0
| L -
== Create a Macromedia Flash movie in SWF format. =

Audio: glnclude audio (sound files)
E Include the slideshow soundtrack
__ Include the slideshow recording

7.1) Keynote export wizard.

Additionally, it is possible to present your slideshow with a dual-display configuration (one display for you “the
presenter” and the other for your students “the audience”). This is similar to the “View Presenter Tools” option

in PowerPoint. In fact, it is even possible to customize the presenter’s second screen using the menu command
Keynote > Preferences > Presenter Display Preferences. Click the “Edit Presenter Layout...” button to
adjust and manage your own personal presenter layout!

800 Presenter Display Preferences (=]

General Rulers Slideshow  Presenter Display | Auto-Correction

Alternate Display: g Use alternate display to view presenter information

Show: g Current Slide

™ Next Slide

M Notes

[ Clock

gTimer
O Time remaining 00:00
@ Elapsed time hh:mm

] Ready to Advance indicator

Edit Presenter Layout... )
Presenter Display

Position and resize these items for use during slide shows. Drag
an item to position it. Drag the resize box to resize the item.

Show: M CurrentSlide [ Clock
™ Next Slide ™ Timer

0y
)

Taiwan Adventures

¥ Notes O Time remaining | 00:00 <) 7.2) Place a checkmark in the “Use
Sf'apsed time  fimm alternate display...” checkbox to enable
S— i dual-display presenter mode. It is also
(Ganee) v p

possible to create a your own presenter
display layout in Kenote! Very cool!

A Trip of a Lifetime!
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